$re = '/v=([-\w]+)/';
$str = 'http://www.youtube.com/watch?v=3YDz-ftqr1g ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);