using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?:\\""|\\\\|[^""])*""|\S+";
string input = @"compile test.json output.bin -location ""Paris, France"" -author ""Charles \""Demurgos\"" ""windowsDirectory\\"" ""otherArg""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}