re = /"(?:\\"|\\\\|[^"])*"|\S+/
str = 'compile test.json output.bin -location "Paris, France" -author "Charles \\"Demurgos\\"" "windowsDirectory\\\\" "otherArg"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end