$re = '/"(?:\\\\"|\\\\\\\\|[^"])*"|\S+/';
$str = 'compile test.json output.bin -location "Paris, France" -author "Charles \\"Demurgos\\"" "windowsDirectory\\\\" "otherArg"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);