#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{{\s*(.+?)\s*}}"
Local $sString = "<!doctype html>" & @CRLF & _
"<html lang="en">" & @CRLF & _
" <head>" & @CRLF & _
" <meta charset="UTF-8">" & @CRLF & _
" <meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0">" & @CRLF & _
" <meta http-equiv="X-UA-Compatible" content="ie=edge">" & @CRLF & _
" <title>Temp demo</title>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <h1>Temp Demo</h1>" & @CRLF & _
"" & @CRLF & _
" <p>Welcome to Temp Demo!</p>" & @CRLF & _
"" & @CRLF & _
" <p>Today's date is {{ currentDate }}</p>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")