import re
regex = re.compile(r"{{\s*(.+?)\s*}}")
test_str = ("<!doctype html>\n"
"<html lang=\"en\">\n"
" <head>\n"
" <meta charset=\"UTF-8\">\n"
" <meta name=\"viewport\" content=\"width=device-width, user-scalable=no, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0\">\n"
" <meta http-equiv=\"X-UA-Compatible\" content=\"ie=edge\">\n"
" <title>Temp demo</title>\n"
" </head>\n"
" <body>\n"
" <h1>Temp Demo</h1>\n\n"
" <p>Welcome to Temp Demo!</p>\n\n"
" <p>Today's date is {{ currentDate }}</p>\n"
" </body>\n"
"</html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")