import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{\\s*(.+?)\\s*\\}\\}";
final String string = "<!doctype html>\n"
+ "<html lang=\"en\">\n"
+ " <head>\n"
+ " <meta charset=\"UTF-8\">\n"
+ " <meta name=\"viewport\" content=\"width=device-width, user-scalable=no, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0\">\n"
+ " <meta http-equiv=\"X-UA-Compatible\" content=\"ie=edge\">\n"
+ " <title>Temp demo</title>\n"
+ " </head>\n"
+ " <body>\n"
+ " <h1>Temp Demo</h1>\n\n"
+ " <p>Welcome to Temp Demo!</p>\n\n"
+ " <p>Today's date is {{ currentDate }}</p>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}