re = /{{\s*(.+?)\s*}}/
str = '<!doctype html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="ie=edge">
<title>Temp demo</title>
</head>
<body>
<h1>Temp Demo</h1>
<p>Welcome to Temp Demo!</p>
<p>Today\'s date is {{ currentDate }}</p>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end