#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\b[a-z]{1,2}-\d{1,2}(?!-)\b"
Local $sString = "And it must matches these situations:" & @CRLF & _
"" & @CRLF & _
"A-1" & @CRLF & _
"B-1" & @CRLF & _
"And ignore these:" & @CRLF & _
"" & @CRLF & _
"A-1-1-1" & @CRLF & _
"A-1-1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")