re = /\b[a-z]{1,2}-\d{1,2}(?!-)\b/im
str = 'And it must matches these situations:
A-1
B-1
And ignore these:
A-1-1-1
A-1-1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end