using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[a-z]{1,2}-\d{1,2}(?!-)\b";
string input = @"And it must matches these situations:
A-1
B-1
And ignore these:
A-1-1-1
A-1-1";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}