import re
regex = re.compile(r"\b[a-z]{1,2}-\d{1,2}(?!-)\b", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("And it must matches these situations:\n\n"
"A-1\n"
"B-1\n"
"And ignore these:\n\n"
"A-1-1-1\n"
"A-1-1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")