const regex = /^(?=(?:.*[A-Z].*){2})(?!(?:.*[A-Z].*){3,})(?=(?:.*\d.*){3})(?!(?:.*\d.*){4,}).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:.*[A-Z].*){2})(?!(?:.*[A-Z].*){3,})(?=(?:.*\\d.*){3})(?!(?:.*\\d.*){4,}).*$', 'gm')
const str = `HelLo1aa2s3d: true
WindowA1k2j3: true
Asjs21js1: false
ASaaak12: false
AAAsjs21js1: false
AA123
AAA123
1234AA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}