import re
regex = re.compile(r"^(?=(?:.*[A-Z].*){2})(?!(?:.*[A-Z].*){3,})(?=(?:.*\d.*){3})(?!(?:.*\d.*){4,}).*$", flags=re.MULTILINE)
test_str = ("HelLo1aa2s3d: true \n"
"WindowA1k2j3: true \n"
"Asjs21js1: false\n"
"ASaaak12: false\n"
"AAAsjs21js1: false\n"
"AA123\n"
"AAA123\n"
"1234AA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")