const regex = new RegExp('(\\d+:\\d+:\\d+\\.\\d+)\\s+(\\S+):\\s+(\\d+:\\d+:\\d+\\.\\d+)\\s+op:\\s+(\\S+)\\s+lun:\\s+(\\/\\S+\\/\\S+)\\s+lba:\\s+(\\d+)\\s+0x[0-9A-F]+\\s+xfer:\\s+(\\d+)\\s+errno:\\s+EIO:\\s+\\'I/O error\\'$', '')
const str = `12:57:57.092 localhost-3: 12:57:57.049 op: write lun: /dev/sdd lba: 15229894656 0x38BC5C000 xfer: 8192 errno: EIO: 'I/O error'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}