re = /(\d+:\d+:\d+\.\d+)\s+(\S+):\s+(\d+:\d+:\d+\.\d+)\s+op:\s+(\S+)\s+lun:\s+(\/\S+\/\S+)\s+lba:\s+(\d+)\s+0x[0-9A-F]+\s+xfer:\s+(\d+)\s+errno:\s+EIO:\s+'I\/O error'$/
str = '12:57:57.092 localhost-3: 12:57:57.049 op: write lun: /dev/sdd lba: 15229894656 0x38BC5C000 xfer: 8192 errno: EIO: \'I/O error\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end