use strict;
my $str = '12:57:57.092 localhost-3: 12:57:57.049 op: write lun: /dev/sdd lba: 15229894656 0x38BC5C000 xfer: 8192 errno: EIO: \'I/O error\'';
my $regex = qr/(\d+:\d+:\d+\.\d+)\s+(\S+):\s+(\d+:\d+:\d+\.\d+)\s+op:\s+(\S+)\s+lun:\s+(\/\S+\/\S+)\s+lba:\s+(\d+)\s+0x[0-9A-F]+\s+xfer:\s+(\d+)\s+errno:\s+EIO:\s+'I/O error'$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}