#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:rs_[0-9]+)?([0-9]*)(?:-.*)?"
Local $sString = "1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"1-dif.1" & @CRLF & _
"10-dif.1" & @CRLF & _
"rs_1" & @CRLF & _
"rs_2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")