const regex = /(?:rs_[0-9]+)?([0-9]*)(?:-.*)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:rs_[0-9]+)?([0-9]*)(?:-.*)?', 'g')
const str = `1
2
3
10
11
1-dif.1
10-dif.1
rs_1
rs_2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}