$re = '/(?:rs_[0-9]+)?([0-9]*)(?:-.*)?/';
$str = '1
2
3
10
11
1-dif.1
10-dif.1
rs_1
rs_2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);