import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:rs_[0-9]+)?([0-9]*)(?:-.*)?";
final String string = "1\n"
+ "2\n"
+ "3\n"
+ "10\n"
+ "11\n"
+ "1-dif.1\n"
+ "10-dif.1\n"
+ "rs_1\n"
+ "rs_2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}