import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*\\/\\/.*$";
final String string = "wolf\n"
+ "// testcattle\n"
+ "sheep\n\n"
+ "deer \n"
+ " // man\n"
+ "// help\n"
+ "//:google.com\n"
+ "http://www.google.com\n"
+ "src= \" //:google.com\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}