$re = '/^\h*\/\/.*$/m';
$str = 'wolf
// testcattle
sheep
deer
// man
// help
//:google.com
http://www.google.com
src= " //:google.com"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);