re = /^\h*\/\/.*$/m
str = 'wolf
// testcattle
sheep
deer
// man
// help
//:google.com
http://www.google.com
src= " //:google.com"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end