package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<span>(\w{3} \d{1,2}, \w{4})<\/span>`)
var str = `<span>Jan 09, 2022</span>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}