$re = '`<span>(\w{3} \d{1,2}, \w{4})<\/span>`';
$str = '<span>Jan 09, 2022</span>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);