const regex = new RegExp('<span>(\\w{3} \\d{1,2}, \\w{4})<\\/span>', '')
const str = `<span>Jan 09, 2022</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}