import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(SOCIEDAD ANONIMA|LIMITADA|L.?T.?D.?A.?|E.?I.?R.?L.?|S.?P.?A.?)|(LIMIT[DA]*?)|(S[\\.\\s]{0,2}?A\\.?)$";
final String string = "SERVICIOS MARITIMOS LITORAL LIMITADA\n"
+ "GINO ALBERTO GATTINI COLLAO\n"
+ "DORA SUSY TAPIA SANTOS\n"
+ "MARIA VERONICA CORDOVA CARBONELL\n"
+ "JEREMY ADRIAN BURFORD BEER\n"
+ "SOC DE INVERSIONES GUINGUIS Y JADAD LTDA\n"
+ "DIGNA ISABEL RETAMAL ARAYA\n"
+ "EVELYN JOHANNA PEREIRA HENRIQUEZ\n"
+ "MANUFACTURAS TEXTILES COLETT INTERNACIONAL LIMITADA\n"
+ "NATALIA CAROLINA ESPINA TEILLIER\n"
+ "INVERSIONES COP DE ROC LIMITADA\n"
+ "AGRICOLA LA RINCONADA DE CALERA DE TANGO LIMITADA\n"
+ "BOSTON SCIENTIFIC LATIN AMERICA B V CHILE LIMITADA\n"
+ "COMERCIALIZADORA PRODUCTOS DEL NORTE Y SERVICIOS LTDA\n"
+ "LATITUD 90 S A\n"
+ "s.a.\n"
+ "s.a\n"
+ " sa\n"
+ " s.a.\n"
+ "sa.\n"
+ "S. A.\n"
+ "COMERCIAL DICU LIMITADA\n"
+ "MARIO DEL VILLAR ESCUTI Y CIA LTDA\n"
+ "AGRICOLA Y FORESTAL LAS BANDURRIAS LIMITADA\n"
+ "CHIRINO Y ASOCIADOS,AUDITORES CONSULTORES LIMITADA\n"
+ "VICHERAT Y PRADENAS LIMITADA\n"
+ "ASESORIAS E INMOBILIARIA FROIMOVICH LIMITADA\n"
+ "KENTUCKY FOODS CHILE LTDA\n"
+ "EPREL LIMITADA INGENIERIA Y CONSTRUCCION\n"
+ "PLASTICOS ARAUCO LIMITADA\n"
+ "INVERSIONES Y CALZADOS GRECO LIMITADA\n"
+ "PESQUERA OMEGA LIMITADA\n"
+ "PERFORACIONES AUSDRILL (CHILE) LTDA\n"
+ "KINTETSU WORLD EXPRESS (CHILE) LIMITADA\n"
+ "SOC PESQUERA QUEHUI S. A.\n"
+ "DORA SUSY TAPIA SANTOSsat\n"
+ "TALLERES LUCAS ATACAMA LIMITADA\n"
+ "AUTOMOTRIZ QUELLE LIMITADA\n"
+ "ERRAZURIZ Y BUSTAMANTE LTDA\n"
+ "MARVELKLEEN SOCIEDAD ANONIMA\n"
+ "BODEGAJE Y ALMACENAJE LIMITADA\n"
+ "SODEXO INVERSIONES S A\n"
+ "COMERCIALIZADORA DE ARTICULOS DE ORTOPEDIA Y TRAUMATOLOGIA\n"
+ "TAYLOR Y MONTGOMERY S A";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}