// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\s(SOCIEDAD ANONIMA|LIMITADA|L.?T.?D.?A.?|E.?I.?R.?L.?|S.?P.?A.?)|(LIMIT[DA]*?)|(S[\.\s]{0,2}?A\.?)$").unwrap();
let string = "SERVICIOS MARITIMOS LITORAL LIMITADA
GINO ALBERTO GATTINI COLLAO
DORA SUSY TAPIA SANTOS
MARIA VERONICA CORDOVA CARBONELL
JEREMY ADRIAN BURFORD BEER
SOC DE INVERSIONES GUINGUIS Y JADAD LTDA
DIGNA ISABEL RETAMAL ARAYA
EVELYN JOHANNA PEREIRA HENRIQUEZ
MANUFACTURAS TEXTILES COLETT INTERNACIONAL LIMITADA
NATALIA CAROLINA ESPINA TEILLIER
INVERSIONES COP DE ROC LIMITADA
AGRICOLA LA RINCONADA DE CALERA DE TANGO LIMITADA
BOSTON SCIENTIFIC LATIN AMERICA B V CHILE LIMITADA
COMERCIALIZADORA PRODUCTOS DEL NORTE Y SERVICIOS LTDA
LATITUD 90 S A
s.a.
s.a
sa
s.a.
sa.
S. A.
COMERCIAL DICU LIMITADA
MARIO DEL VILLAR ESCUTI Y CIA LTDA
AGRICOLA Y FORESTAL LAS BANDURRIAS LIMITADA
CHIRINO Y ASOCIADOS,AUDITORES CONSULTORES LIMITADA
VICHERAT Y PRADENAS LIMITADA
ASESORIAS E INMOBILIARIA FROIMOVICH LIMITADA
KENTUCKY FOODS CHILE LTDA
EPREL LIMITADA INGENIERIA Y CONSTRUCCION
PLASTICOS ARAUCO LIMITADA
INVERSIONES Y CALZADOS GRECO LIMITADA
PESQUERA OMEGA LIMITADA
PERFORACIONES AUSDRILL (CHILE) LTDA
KINTETSU WORLD EXPRESS (CHILE) LIMITADA
SOC PESQUERA QUEHUI S. A.
DORA SUSY TAPIA SANTOSsat
TALLERES LUCAS ATACAMA LIMITADA
AUTOMOTRIZ QUELLE LIMITADA
ERRAZURIZ Y BUSTAMANTE LTDA
MARVELKLEEN SOCIEDAD ANONIMA
BODEGAJE Y ALMACENAJE LIMITADA
SODEXO INVERSIONES S A
COMERCIALIZADORA DE ARTICULOS DE ORTOPEDIA Y TRAUMATOLOGIA
TAYLOR Y MONTGOMERY S A";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}