import re
regex = re.compile(r"(__|--)((?:(?!\1).)+)\1")
test_str = ("__word1__ not_italic __a__ --bolder--\n\n"
"this is an __italic part of the sentence_with underscores__")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")