re = /(__|--)((?:(?!\1).)+)\1/
str = '__word1__ not_italic __a__ --bolder--
this is an __italic part of the sentence_with underscores__'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end