using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(FAST\.|LT|LESS THAN|below|<|LE|<=|GT|Greater THAN|above|>|GE|>=) ?(\d+.\d+|\d+)(-)(\d+.\d+|\d+)";
string input = @"FAST.65
FAST.65-160
<114
>289
<=152
>=107
10.9
111.11
12.20
LESS THAN 0.1
LESS THAN 5
LESS THAN 9999
< 0.1
< 999
< 99999.99
<5
< 5
<5.55
<= 6
LE 6
<=666.666
LT 6
LT 6.666
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}