const regex = /(FAST\.|LT|LESS THAN|below|<|LE|<=|GT|Greater THAN|above|>|GE|>=) ?(\d+.\d+|\d+)(-)(\d+.\d+|\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(FAST\\.|LT|LESS THAN|below|<|LE|<=|GT|Greater THAN|above|>|GE|>=) ?(\\d+.\\d+|\\d+)(-)(\\d+.\\d+|\\d+)', '')
const str = `FAST.65
FAST.65-160
<114
>289
<=152
>=107
10.9
111.11
12.20
LESS THAN 0.1
LESS THAN 5
LESS THAN 9999
< 0.1
< 999
< 99999.99
<5
< 5
<5.55
<= 6
LE 6
<=666.666
LT 6
LT 6.666
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}