re = /(FAST\.|LT|LESS THAN|below|<|LE|<=|GT|Greater THAN|above|>|GE|>=) ?(\d+.\d+|\d+)(-)(\d+.\d+|\d+)/
str = 'FAST.65
FAST.65-160
<114
>289
<=152
>=107
10.9
111.11
12.20
LESS THAN 0.1
LESS THAN 5
LESS THAN 9999
< 0.1
< 999
< 99999.99
<5
< 5
<5.55
<= 6
LE 6
<=666.666
LT 6
LT 6.666
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end