use strict;
my $str = 'FAST.65
FAST.65-160
<114
>289
<=152
>=107
10.9
111.11
12.20
LESS THAN 0.1
LESS THAN 5
LESS THAN 9999
< 0.1
< 999
< 99999.99
<5
< 5
<5.55
<= 6
LE 6
<=666.666
LT 6
LT 6.666
';
my $regex = qr/(FAST\.|LT|LESS THAN|below|<|LE|<=|GT|Greater THAN|above|>|GE|>=) ?(\d+.\d+|\d+)(-)(\d+.\d+|\d+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}