// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:.*?(\d{1,}\/\d{1,}\/\d{2,})){2}").unwrap();
let string = "21/6/20 - 18/9/18 - Ubicazione pagina 33 del DVR
\\d{1,}\\/\\d{1,}\\/\\d{2,}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}