using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{{([\w\.]+)(?:\s+(\w+)=(?:(""(?:[^""]*)"")|([\w\.]+)))*\}\}";
string input = @"{{token arg=1 id=2 class=3}}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}