re = /\{{([\w\.]+)(?:\s+(\w+)=(?:("(?:[^"]*)")|([\w\.]+)))*\}\}/
str = '{{token arg=1 id=2 class=3}}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end