const regex = /\{{([\w\.]+)(?:\s+(\w+)=(?:("(?:[^"]*)")|([\w\.]+)))*\}\}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{{([\\w\\.]+)(?:\\s+(\\w+)=(?:("(?:[^"]*)")|([\\w\\.]+)))*\\}\\}', '')
const str = `{{token arg=1 id=2 class=3}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}