using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@e(?:[^u]reka|u[^r]eka|ur[^e]ka|ure[^k]a|urek[^a]|eurk[^a])\.com";
string input = @"jcarter@euneka.com
jcarter@eurrka.com
jcarter@eur4ka.com
jcarter@eur3ka.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}