import re
regex = re.compile(r"@e(?:[^u]reka|u[^r]eka|ur[^e]ka|ure[^k]a|urek[^a]|eurk[^a])\.com", flags=re.MULTILINE)
test_str = ("jcarter@euneka.com\n"
"jcarter@eurrka.com\n"
"jcarter@eur4ka.com\n"
"jcarter@eur3ka.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")