$re = '/@e(?:[^u]reka|u[^r]eka|ur[^e]ka|ure[^k]a|urek[^a]|eurk[^a])\.com/m';
$str = 'jcarter@euneka.com
jcarter@eurrka.com
jcarter@eur4ka.com
jcarter@eur3ka.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);