# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)(?=\D)|(?<=\D)(?=\d)/\n/g;t' <<< "46MTS007"