const regex = /(?<=\d)(?=\D)|(?<=\D)(?=\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d)(?=\\D)|(?<=\\D)(?=\\d)', 'g')
const str = `46MTS007`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);