$re = '/(?<=\d)(?=\D)|(?<=\D)(?=\d)/';
$str = '46MTS007';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;