import re
regex = re.compile(r"(?<=\d)(?=\D)|(?<=\D)(?=\d)")
test_str = "46MTS007"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)