package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z]{7}\d`)
var str = `новая версия вчера - version1
новая версия сегодня - version2
новая версия завтра - version3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}