$re = '/[a-zA-Z]{7}\d/m';
$str = 'новая версия вчера - version1
новая версия сегодня - version2
новая версия завтра - version3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);