re = /[a-zA-Z]{7}\d/m
str = 'новая версия вчера - version1
новая версия сегодня - version2
новая версия завтра - version3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end