// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-zA-Z]{7}\d").unwrap();
let string = "новая версия вчера - version1
новая версия сегодня - version2
новая версия завтра - version3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}